Revenue Currency Attribute defaults to incorrect currency in Batch

Revenue Currency Attribute defaults to incorrect currency in Batch.
We are currently evaluating this issue and will update this article when we have more information.

Steps to Duplicate

  1. Go to Administration>Attribute Categories
  2. Find the revenue attribute named TEST Attribute Currency Display. Notice it is a currency attribute
  3. Go Revenue
  4. Select Add a payment
  5. Select Constituent Lookup
  6. Enter amount, designation, payment method, etc.
  7. Save the payment
  8. Once the payment opens select the attributes tab
  9. Add a new attribute
  10. Select Attribute Type of TEST Attribute currency Display
  11. Notice the Attribute is defaulting to Australian Dollars which is correct. 
  12. Go to Batch Entry
  13. Add a new batch and select Batch Template named Currency Attribute Test
  14. Once the batch opens scroll over to the TEST Attribute currency Display attribute field and it is defaulting to Euros.  It should be in base currency (AUD) not organisational currency (EURO)

Was this article helpful?


Thanks for your feedback! Did this solve your issue?

Comments (optional):


Thanks for your feedback!
We're glad it was helpful but sorry it didn’t solve your issue. If you need assistance, click Chat with Support below.
We’re sorry to hear that. Please tell us why.

 I don't like how this works.

 The answer is confusing.

 The answer didn't match what I was searching for.

Additional Comments (optional):


Thanks for your feedback! If you need assistance, click Chat with Support below.
Thanks for your feedback. Help us make our products even better by sharing details in our Idea Banks or our online Community.
Thanks for letting us know. We'll work on clarifying the information in the article. If you need assistance, click Chat with Support below.
Thanks for letting us know. We'll work on updating the search engine to return more relevant results.