Is Adobe Reader DC compatible with The Financial Edge?

You can use Adobe Acrobat Reader to view sample reports and export documents. The Financial Edge does not automatically install Adobe Acrobat Reader, as it is not required to be able to run FE. If you try to export a document in a PDF format though, and you do not have Adobe reader installed, you will receive a warning on the workstation.
Adobe Acrobat Reader is not required in order to run Blackbaud software and we do not test all third-party products or versions with our software when the product is not required to run The Financial Edge.

At this time, Adobe Reader DC is not currently compatible with The Financial Edge version 7.87. We are currently evaluating this and will update this article when we have more information.

Alternatively, Adobe Reader XI is currently compatible with The Financial Edge and should be supported by Adobe until 2017.

Steps to Duplicate

1. Records > Vendor Records > Media Tab > attempt to attach media
2. FE freezes

Freezing may also occur when attempting to open an already attached PDF file.

Was this article helpful?